aboutsummaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* TODO Implement redo-stampredo-stampTharre2016-11-015-2/+23
|
* Move utility functions to util.cTharre2016-10-313-39/+45
|
* Split add_prereq() into general and specificTharre2016-10-313-11/+25
|
* Fix reference to free'd memory in handle_c()Tharre2016-10-281-2/+3
|
* Implement logging using REDO_DEBUG env variableTharre2016-10-273-0/+17
|
* Make sha1_to_hex() return a null-terminated stringTharre2016-10-261-1/+3
|
* Make redo shortcut againTharre2016-10-251-2/+7
|
* Cleanup handle_c() a bitTharre2016-10-251-51/+50
|
* Remove REDO_MAGIC handling code from handle_c()Tharre2016-10-252-14/+0
|
* Implement modification time (ctime) checkTharre2016-08-031-34/+74
| | | | | | Hashing over the contents of dependencies over and over again is slow. To avoid this, we first check the modification time (ctime), and only if that check fails we generate a hash.
* Improve CC.doTharre2016-08-031-2/+2
|
* Fix overflow error when there are too many fieldsTharre2016-08-032-6/+7
|
* Always show debug() statements to the compilerTharre2016-08-031-6/+8
|
* Implement new dependency storage systemTharre2016-07-267-110/+349
|
* Add various testsTharre2016-06-252-2/+38
|
* Cleanup dep_info structTharre2016-06-251-23/+20
|
* Fix invalid memory access bug in parse_shebang()Tharre2016-05-221-2/+2
|
* Handle absolute $3 correctlyTharre2016-05-021-1/+5
|
* Make $3 an absolute pathTharre2015-09-162-1/+13
|
* Add a few testsTharre2015-09-134-0/+105
|
* Replace Makefile with all.doTharre2015-07-132-60/+29
|
* Replace custom test-suite with sharnessTharre2015-07-1341-195/+924
| | | | | | | This should make the hole test-suite a bit more standard (by outputting TAP), as well as making it easier to test redo in a controlled environment. In contrast to bats, sharness requires no external dependencies.
* Ensure all environment variables are setTharre2015-06-151-3/+6
|
* Actually write the source flag into the dep storeTharre2015-06-131-0/+2
|
* Don't create files with executeable permissionsTharre2015-06-131-1/+1
|
* Make `general` path from get_doscripts() absoluteTharre2015-06-131-9/+13
|
* Designated initializers set values to 0 alreadyTharre2015-06-131-6/+0
|
* Only hash files onceTharre2015-06-131-24/+31
|
* Make sha1_to_hex staticTharre2015-06-131-1/+1
|
* Use dep_info earlier to avoid duplicationTharre2015-06-131-80/+90
| | | | | | This is a prerequisite for avoiding hashing one and the same file multiple times. This also keeps the necessary parsing code for the dependency store out of build_target() into handle_c() where it belongs.
* Fix waitpid() error message and 2 if statementsTharre2015-06-131-7/+5
|
* Don't export build_target()Tharre2015-06-132-3/+1
| | | | | build_target() should not be called from outside, update_target() should be used instead.
* Pass 0755 directly instead of using POSIX macrosTharre2015-06-101-2/+1
| | | | | I'm not perfectly sure if this actually violates the POSIX standard or not, but in practice all systems seem to accept it.
* Fix error message for unsupported newlinesTharre2015-06-081-1/+1
|
* Rename `dependency file` to `dependency record`Tharre2015-05-251-5/+5
|
* Rename `do-file` to `.do script`Tharre2015-05-251-38/+39
|
* Fix piping to /dev/nullTharre2015-05-252-2/+2
|
* Fix some sh compatibility problemsTharre2015-05-252-2/+4
|
* Replace current tests with a hole new test suiteTharre2015-05-2548-71/+192
| | | | | | | | This new test suite is based on just on do scripts, much like apenwarr's redo implementation has done it. This makes tests both simpler and free from any additional dependencies. The naming was also improved a lot. There are also a lot of new tests, and many more to be implemeted later.
* Ignore generated doc filesTharre2015-05-251-0/+4
|
* Small rename and code simplificationTharre2015-05-252-8/+7
|
* Small clarificationTharre2015-05-251-1/+1
|
* Store dependencies as plain text instead of binaryTharre2015-05-252-75/+51
| | | | | | | | Binary files are hard to debug, and even while the code required to parsing them is simpler it's not worth the tradeoff. Note that handling of newlines in target names is not implemented yet, they require some sort of special escaping.
* Use full path instead of one concatenated filenameTharre2015-05-244-52/+23
| | | | | Creation of the redo store (.redo/) is now silent, that should probably be reimplemented in a better way at a later time.
* Fix some issues with pathsTharre2015-05-052-11/+5
|
* Make redo lines colored to enhance readabilityTharre2015-05-051-1/+1
|
* Fix path quoting in the clean targetTharre2015-05-051-1/+1
|
* Install redo into /usr/local/bin by defaultTharre2015-04-082-5/+5
|
* Add basic man pages for documentationTharre2015-04-044-0/+184
|
* Always use the CWD of the dofile, not the targetTharre2015-02-201-10/+5
|