aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTharre <tharre3@gmail.com>2014-04-08 09:19:33 +0200
committerxRamses <tharre3@gmail.com>2014-04-08 09:19:33 +0200
commitc766f073e60c3aa51a3cc1555af87ded5823e5a0 (patch)
tree43595070e833b251b3f7ac7e94e5e992918194ef /configure.ac
downloadredo-c766f073e60c3aa51a3cc1555af87ded5823e5a0.tar.gz
redo-c766f073e60c3aa51a3cc1555af87ded5823e5a0.tar.xz
redo-c766f073e60c3aa51a3cc1555af87ded5823e5a0.zip
Initial codebase
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..9b73edc
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,30 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.68])
+AC_INIT([redo], [pre-0.01], [BUG-REPORT-ADDRESS])
+AC_CONFIG_SRCDIR([src/redo-ifchange.c])
+AC_CONFIG_HEADERS([config.h])
+
+# Checks for programs.
+AC_PROG_CXX
+AC_PROG_CC
+
+# Checks for libraries.
+
+# Checks for header files.
+AC_CHECK_HEADERS([stddef.h stdint.h stdlib.h string.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_CHECK_HEADER_STDBOOL
+AC_TYPE_OFF_T
+AC_TYPE_PID_T
+AC_TYPE_SIZE_T
+
+# Checks for library functions.
+AC_FUNC_FORK
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+AC_CHECK_FUNCS([strdup strerror strrchr])
+
+AC_OUTPUT